///
Search

카드 정렬하기

시간 제한
메모리 제한
제출
정답
맞힌 사람
정답 비율
2 초
128 MB
53879
18354
14074
33.631%

문제

정렬된 두 묶음의 숫자 카드가 있다고 하자. 각 묶음의 카드의 수를 A, B라 하면 보통 두 묶음을 합쳐서 하나로 만드는 데에는 A+B 번의 비교를 해야 한다. 이를테면, 20장의 숫자 카드 묶음과 30장의 숫자 카드 묶음을 합치려면 50번의 비교가 필요하다.
매우 많은 숫자 카드 묶음이 책상 위에 놓여 있다. 이들을 두 묶음씩 골라 서로 합쳐나간다면, 고르는 순서에 따라서 비교 횟수가 매우 달라진다. 예를 들어 10장, 20장, 40장의 묶음이 있다면 10장과 20장을 합친 뒤, 합친 30장 묶음과 40장을 합친다면 (10 + 20) + (30 + 40) = 100번의 비교가 필요하다. 그러나 10장과 40장을 합친 뒤, 합친 50장 묶음과 20장을 합친다면 (10 + 40) + (50 + 20) = 120 번의 비교가 필요하므로 덜 효율적인 방법이다.
N개의 숫자 카드 묶음의 각각의 크기가 주어질 때, 최소한 몇 번의 비교가 필요한지를 구하는 프로그램을 작성하시오.

입력

첫째 줄에 N이 주어진다. (1 ≤ N ≤ 100,000) 이어서 N개의 줄에 걸쳐 숫자 카드 묶음의 각각의 크기가 주어진다. 숫자 카드 묶음의 크기는 1,000보다 작거나 같은 양의 정수이다.

출력

첫째 줄에 최소 비교 횟수를 출력한다.

예제 입력 1

3 10 20 40
Plain Text
복사

예제 출력 1

100
Plain Text
복사

예제 입력 2

1 10
Plain Text
복사

예제 출력 2

0
Plain Text
복사

내 풀이

95%에서 틀린다
import heapq n = int(input()) cards = [] for _ in range(n): heapq.heappush(cards, int(input())) res = 0 while cards: temp = [] # print(cards) if len(cards) >= 2: for i in range(2): temp.append(heapq.heappop(cards)) else: temp.append(heapq.heappop(cards)) temp_sum = sum(temp) res += temp_sum if cards: heapq.heappush(cards, temp_sum) print(res)
Python
복사

개선 풀이

import heapq n = int(input()) cards = [] for _ in range(n): cards.append(int(input())) heapq.heapify(cards) res = 0 # print(cards) if len(cards) >= 2: while cards: temp = [] # print(cards) for i in range(2): temp.append(heapq.heappop(cards)) temp_sum = sum(temp) res += temp_sum if cards: heapq.heappush(cards, temp_sum) else: res += heapq.heappop(cards) print(res)
Python
복사
역시 95%에서 틀린다
import heapq n = int(input()) cards = [] for _ in range(n): cards.append(int(input())) heapq.heapify(cards) res = 0 # print(cards) if len(cards) >= 2: while cards: temp = [] # print(cards) for _ in range(2): temp.append(heapq.heappop(cards)) temp_sum = sum(temp) res += temp_sum if cards: heapq.heappush(cards, temp_sum) # else: # res += 0 print(res)
Python
복사
n=1 일 때는, 비교 대상이 없기 때문에 0을 뽑아내야한다.!

참고 코드